PDA

View Full Version : 195 thermostat



Jairek
09-28-2010, 03:08 AM
well i just put a new thermostat in from finding there wasnt one is the car and i guess it controls better but have the time the car goes up to 220 a lil past then goes back to like 198 what would cause this

LordDurock
09-28-2010, 04:11 AM
a system with a T stat will run slightly higher then what the inlet temp of the water pump is. a system with a T stat, the temp will stay around the t stat temp (195 in this case) unless the coolant temp get with in a small enough range of the t stat opening temp (195 in this case) than they system will run hotter. going up that high would mean something else is wrong in the system like a rad that doesnt cool well or a bum fan.

Jairek
09-28-2010, 09:32 PM
yea im going to flush the system see if theres any gunk my fan kicks on like at 220 over that is that bad

Jairek
09-28-2010, 10:55 PM
so broke my drain cock jeeeezzz so off to buy another had to rip radiator out and found out my radiator was made in 93 lol thats old but i also found out there was a huge ass pile off dirt just jammed up in the middle of the radiator i was like wtf the ac radiator has nothing on it. but now the drain cock was so old the 2nd time i put it on it just busted when i was pouring antifreeze in filling it up jesus then it snaps goes all over the place half a jug what my luck

Prospeeder
02-21-2011, 06:08 PM
so broke my drain cock jeeeezzz so off to buy another had to rip radiator out and found out my radiator was made in 93 lol thats old but i also found out there was a huge ass pile off dirt just jammed up in the middle of the radiator i was like wtf the ac radiator has nothing on it. but now the drain cock was so old the 2nd time i put it on it just busted when i was pouring antifreeze in filling it up jesus then it snaps goes all over the place half a jug what my luck

Thats your problem, replace the radiator with a new one, I got one online somewhere 95 bucks shipped to my door.

Century7667
02-21-2011, 06:54 PM
so broke my drain cock jeeeezzz so off to buy another had to rip radiator out and found out my radiator was made in 93 lol thats old but i also found out there was a huge ass pile off dirt just jammed up in the middle of the radiator i was like wtf the ac radiator has nothing on it. but now the drain cock was so old the 2nd time i put it on it just busted when i was pouring antifreeze in filling it up jesus then it snaps goes all over the place half a jug what my luck

Probably a good thing that thing broke. I've see radiator flush kill more than one cooling system. The only thing I'd put in there is distilled water and Prestone (or whatever). Spectra, a rad manufacturer agrees. I saw a iron head 2.8 make milk shakes one day after a "flush" using a chemical additive.

Ken T.

lemons bob
02-21-2011, 07:32 PM
93 isn't that old, my whole car is older than that and it looks like it has the original radiator in it and it was clean. Had to run water in it for the race and when we emptied it to put antifreeze in for winter the water was clean and clear as could be. Now when you said there was a huge pile of dirt in the middle of the radiator do you mean inside the radiator or on the outside in the fins. If its outside just take a hose to it and clean it out no need for a new one for dirt on the fins. if its on the inside I'd be more curious of what that stuff is since its probably been going through the engine or came out of the engine.

Jairek
03-13-2012, 10:48 PM
my radiator was full of dirt on the outside..... i always get boiling and it runs normal temps it just seems to boil a lot the antifreeze... and the no 4th gear at highway speeds when im doing 55 for at least 10 miles itll drop out of 4th and stay in 3rd till i restart vehicle....

lemons bob
03-14-2012, 03:35 PM
I'd clean off the radiator and see if that helps. if its full of dirt it might be not getting air through it meaning the radiator really isn't cooling things.

You should have a transcooler in the radiator so its possible the transfluid isn't getting cooled either, but I would first make sure you have enough transfluid. Not shifting right is often an indication of low fluid.

Jairek
03-17-2012, 02:56 AM
Yeaaa I got alot dirt out while ago... I used to get a waterfall sound in the car... I dont understand about the trans getting to hot is it possible for trans cooler to get clogged? The radiator hasn't been flushed for 100 k miles like when you hook a high pressure water up to it I think I've never done that but only change antifreeze never flushed anything...