Announcement

Collapse
No announcement yet.

My STE stranded me!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Ish. I redid the resistance tests on that injector 4-way because i thought i may have done it wrong. I did. One of the tests was showing lower than the book said and then said to ohm.out each injector. .As Luck would have it the 2 injectors you can get (cyl 1 & 6) to or at least get the Harness off of the top of it to ohm test without removing the plenum .....on the one injector on the driver side (cyl 1 i believe) was damn near zero showing about 1.2ohms. The other was 12.5 and i had recorded all.of them 12.5 to 12.7 when i re-installed them 2000mi ago after refurbishment... I left that one disconnected and the car fired right up.
    How does one bum injector take out all of them?
    Oh well at least i know whats wrong now.
    Pontiac6ksteawd called it.
    Last edited by 73blazer; 06-03-2019, 05:42 AM.

    Comment


      #17
      Good to know you got it figured out. Well they're 3 each in parallel, so one can take out the others. If you've got almost no ohms on one, then the ECM thinks the whole bunch is almost shorted out. Just like if you've got a shorted socket on a lighting circuit, it doesn't matter that all the other lights are good, the fuse still blows or the circuit overheats. At least the ECM knew to save itself.
      Last edited by tlc1976; 06-03-2019, 04:54 AM.
      1989 Celebrity CL 4 door, 3.1 MPFI, 4 speed auto, summer daily driver
      1989 Cutlass Cruiser wagon, 3.1 MPFI, 4 speed auto, special summer ride
      1996 Cherokee XJ 4 door, 4.0, 5 speed, winter daily driver & towing vehicle
      1991 Tracker 2 door, 1.6, 5 speed, needs work
      Previously several Celebritys, 6000s, & 2 U-vans

      Comment


        #18
        Their resistance can change or short intermittently too. The short went away momentarily when your car started.

        I am personally very skeptical of spending money on refurbishment or cleaning of 1st generation Multitec injectors. They were too flawed and too trouble prone with age.
        Last edited by CorvairGeek; 06-03-2019, 05:38 PM.
        Jerry

        Comment


          #19
          Thanks to this post, i just figured out the issue with my cruiser wagon. After a sudden case of crank and no start, i changed the fuel pump and sending unit, still no start. Changed the crank position sensor, still no start. Check resistance on the injectors, one reads bad. Unplug bad injector car runs (crappy but runs)!! Thanks again!!

          Comment


            #20

            I ordered a set of Accel injectors 150615, set of 6 ( (or 150115 if just a single) 15lbs/hr. Their catalog as well as Advanced Auto's say "Exact fit"
            Yeah, they're short. OEM ones are ~74.95mm, these are 72mm. You can't seat the rail, I tried also without the clips to see if mabey letting the upper oring set lower inthe rail, nope, it's on the edge, I'd have fuel spraying everywhere like that. Friggen junk.
            Thanks for wasting my day, and more time now returning these and sourcing ones that actually work. WTF are these even made for anyway?
            Last edited by 73blazer; 06-09-2019, 11:44 PM.

            Comment


              #21
              Well, I take that back. They do fit. See that upper groove in the injector? There's special instructions (that were not included with mine, I only found them on summit racing's website actually, not where I bought them, and they're not on accel website either), "Some GM Engines will require use of the clip in the upper groove". Real nice. So you can use the clips, in the upper groove, have to put them in the rail first, and that oring is barely seated in the rail, but, clips on, and they're seated and it all seats down in the intake holes. Still wonder why they're short, most likely to fit other applications, but do these injectors really go beyond GM?
              I dunno, car started up and ran great, no issues.
              BTW these have three holes on the bottom for spray, unlike the OEM single big hole. Supposedly, better atomization. We'll see.

              Comment


                #22
                I am curious to see what you think of them in operation. Accel does have a lot of injectors for a lot of applications (could be good or bad).
                Jerry

                Comment


                  #23
                  The set that was on my Cruiser when I got it was a nearly new set of Lucas injectors. They too have the 3 holes at the bottom, apparently that's how they do them now, they call it disc style instead of pintle style. Apparently they give you better fuel control. Apparently the spray pattern is different too.

                  There's still something going on with mine, high BLM but runs great with the EGR blocked, normal BLM but misses under light load with the EGR unblocked. But there's definitely a difference in the injectors. The Multecs give a high but still varying BLM, they ohm correctly and dont leak. The Lucas's peg the BLM at 156 and it won't budge, also seemed to suck a lot more gas. So I'm running the Multecs.

                  I'm curious if you will notice any difference with your disc injectors, compared to when the old ones were running good.
                  1989 Celebrity CL 4 door, 3.1 MPFI, 4 speed auto, summer daily driver
                  1989 Cutlass Cruiser wagon, 3.1 MPFI, 4 speed auto, special summer ride
                  1996 Cherokee XJ 4 door, 4.0, 5 speed, winter daily driver & towing vehicle
                  1991 Tracker 2 door, 1.6, 5 speed, needs work
                  Previously several Celebritys, 6000s, & 2 U-vans

                  Comment


                    #24
                    I drove it to a customer of mine 230mi away yesterday and will be here all week. Havn't checked gas mileage yet. Throttle response does seem improved, and it idles a tad smoother. Seems alot "happier", smoother at highway cruiser speed too. But I'm not really sure I've ever had a set of good injectors on that car. When I got it it was sitting for a decade and gas tank was full crap. It ran but fairly rough. New senders, fuel pump, filter, renu tank, sent injectors out for cleaning. Mr. Injector said two of mine were not fixable and I bought two "new" ones from some place in mid-michigan. Well, it was one of the "new" ones that actually shorted out and went bad. Perhaps it was on the verge of bad to start with. Also the 4 overhauled injectors ohm'd out at 9.5,10.5,10.9 and 12.5 when I removed those last weekend, ~1000mi post overhaul. So three of these are low too. I don't think I'd send out 1st gen multec's for overhaul anymore, really not worth it.
                    So I think I never really had a good set of injectors pre-fuel system overhaul or post. Well, until now that is.

                    Comment


                      #25
                      I've used a couple sets of Accel injectors in TPI Camaros and they have worked great. They were shorter than the originals but it wasn't an issue. One set was even the older yellow ones that came before the "improved" ones.
                      -Andy

                      '86 Eurosport VR coupe
                      '86 Eurosport sedan
                      '88 Eurosport VR coupe
                      '89 Eurosport wagon

                      Comment


                        #26
                        Gas mileage over a ~500mi trip of 70% 70mph and 30% 45-55mph , no stop and go or "city" driving ....avg. 22.4
                        That's a slight improvment. it used to be between 20 and 21 before. But like I said, I'm not sure I ever had "good" injectors on that car.

                        Comment


                          #27
                          Originally posted by 73blazer View Post
                          Gas mileage over a ~500mi trip of 70% 70mph and 30% 45-55mph , no stop and go or "city" driving ....avg. 22.4
                          That's a slight improvment. it used to be between 20 and 21 before. But like I said, I'm not sure I ever had "good" injectors on that car.
                          Awesome! I agree with your assessment wholeheartedly. Thanks for the update.
                          Jerry

                          Comment


                            #28
                            Great to hear your mileage has improved and the car is running better. My Celeb typically gets 32 highway but it doesn't have the AWD parts turning. My old 3.1 6000 wagon got 30 highway, my 2.8 6000 wagon got 28 highway and that was in the winter. The Cruiser is only getting 23-24 so something's up with it still.
                            1989 Celebrity CL 4 door, 3.1 MPFI, 4 speed auto, summer daily driver
                            1989 Cutlass Cruiser wagon, 3.1 MPFI, 4 speed auto, special summer ride
                            1996 Cherokee XJ 4 door, 4.0, 5 speed, winter daily driver & towing vehicle
                            1991 Tracker 2 door, 1.6, 5 speed, needs work
                            Previously several Celebritys, 6000s, & 2 U-vans

                            Comment


                              #29
                              Well, it's getting it's "rated" MPG, EPA has it rated at 15/22 (or 17/23 under the "old" estimate method) ...
                              so that's all I can ask for. with a 3sp trans and the AWD hardware, 22 really isn't bad. I'm not complaining anyway.
                              The avg curb weight of a 6cyl 6000 is 2800-2900lbs. The listed curb weight of the STE AWD is 3322lbs. Some of that weight is actual weight the motor has to turn too..

                              Comment

                              Working...
                              X