Announcement

Collapse
No announcement yet.

the 85 celebrity

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • turbokinetic
    replied
    Originally posted by cody1234 View Post
    This thing is really starting to look ugly. Bad primer. Rust coming through.. Stupid lying rust converting paint..
    Awe no..... that is going to be very time-consuming to fix. Those so-called "rust converting" paints only work on metal with a "small surface layer" of rust. They will not prevent deep pitting from continuing to rust.

    Leave a comment:


  • cody1234
    replied
    This thing is really starting to look ugly. Bad primer. Rust coming through.. Stupid lying rust converting paint..

    Leave a comment:


  • cody1234
    replied





    Leave a comment:


  • cody1234
    replied
    All bad news

    Leave a comment:


  • cody1234
    replied
    Aaaahhhhhhh.... Rust problemss.

    Leave a comment:


  • cody1234
    replied
    https://youtu.be/8EmpWEKWp_4

    Leave a comment:


  • cody1234
    replied
    Originally posted by turbokinetic View Post
    I believe you may be onto something with the timing. Try advancing it and see if you can "change" the performance.
    And yes. I found 2 loose spark plugs and advanced it by about 5 degrees. And man WHAT A DIFFERENCE. That thing just about lays rubber when i gun it. Takes off like a dart now. .

    Leave a comment:


  • cody1234
    replied
    Power steering is functional again. I have come across my idle problem again. Getting tired of that. I will post a video of that. It will run fine for a while. Start acting up. Correct itself and run fine... Then act up again.. It just seems random. But it hasn't really been too bad since the rebuilt carb and egr and gaskets were put on. I was doing 65-75 up the highway and yes.. UP the highway. Lots of big hills. First i have had it up that fast since the fix. I don't like pushing this thing too hard.

    . It beats me. Unless it blew a hose off again. I dont think it did. But if it did maybe i should super glue the things on so they dont come off. Except last time the hoses fell off it always dieseled when i shut it off. It only seems bad in park. No load. In drive it still kinda misses but it isnt too bad. Maybe it just needs the 30k plugs tuneup.

    Typical. One car always has issues. When i had subaru and saturn the saturn always had issue but subaru was fine. Junk the Saturn get the celebrity then the Subaru is messed up. Junk that cuz it was totalled. Get the buick roadmaster. Which had issues and i got the celebrity running very well compared to before. Then get the buick running basically like new and now the celebrity starts acting up.. Im starting to think this behavior is normal.

    Leave a comment:


  • cody1234
    replied
    I have not forgotten. Here is a pic of "the works" of the smoker system



    Very simple and is not fully completed. I have upgraded from a 1 qt container to removing the junk emissions can and putting a full 5 qt jug in place. And this system so far can pump basically any liquid. I have ran kerosene.. Oil. Used black oil. Old coolant. Flat soda. That smells nasty. Water.. . The system works. I would recommend having a knocked out cat if using old oil. And a larger muffler. Oem type. Not a glasspack. If the rpms are high sometimes it blows half the oil out and makes a mess. I got a muffler from a 1999 chevy lumina. Not as bad now. And if i hold that pump running while flooring it. It is alot of smoke. The video i posted is just the remaining burning smoke after i let off the button. As i could not drive and video while holding the button.

    Leave a comment:


  • cody1234
    replied
    Trying to eliminate that electrical rats nest in there. I got everything to do it. Just need my brain to work. And a nice day would be nice

    Leave a comment:


  • cody1234
    replied








    Leave a comment:


  • cody1234
    replied
    Originally posted by a1veedubber View Post
    I have that same Pioneer EQ in my Car Audio stash!
    Haha. I got it along with other equipment out of a 1976 coupe deville at the local scrap yard. Not sure how old the eq is but i got a sony cassette radio made in 1989. Old shaft style along with a 1989 leer jet 100w amp and a big old 200w 4 channel amp. I forget the brand but i think it says glr on the front? Its huge. And that eq. And so far the eq and the leer jet amp is the only things that work. The sonys pre amp is burned out and the big amp shorted out one day and hasnt worked since. But for $20 i guess its still a good deal

    Leave a comment:


  • a1veedubber
    replied
    I have that same Pioneer EQ in my Car Audio stash!

    Leave a comment:


  • cody1234
    replied
    https://m.youtube.com/watch?v=FpImjS_GipY

    Input mod was successful on my 1988 celebrity radio. Free junkyard radio. Equals test subject.

    Leave a comment:


  • cody1234
    replied
    Roadmaster. 1992 tbi. 350. Replaced spark plugs. Wires dist cap n rotor fuel filter. Fuel pressure regulator. Oil. Filter. Air filter. Cleaned injector plugs. Etc. I noticed the coolant may not go up as high as it should on the guage. Not really sure where it settles. But i put a brand new 195 thermostat in it. All that made it idle smoother. Not much else

    Leave a comment:

Working...
X