Announcement

Collapse
No announcement yet.

the 85 celebrity

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #91
    Originally posted by cody1234 View Post
    I may have to get a lil sandblaster. I got 2 cars that can use it.. And between them both there is enough rust to get a good bit of use from it.. The celebrity is all body rust mostly.. But the big buick was never undercoated.. But since its a full sized gm. It appears they used bomb proof steel that would take 80 years to hurt it.. Tempted to blast all the rust off the bottom and get it undercoated. Not worried about perfection there. Just rust proofing. Idk about frames. Being hollow spots u cant get to.
    Body on the buick is almost perfect. Couple spots on the hood where i believe a branch or something smacked it. Chip on the hood. Small ding. Little rust under it. Not bad though.
    Yeah, a little blaster can certainly come in handy for rust removal. Just be sure to wear good eye & respiratory protection and avoid using sand/grit that contains silica .. it's bad stuff to get in your lungs!

    And be aware that even a fairly small blaster can require quite a bit of air. So make sure you have a compressor that's up to the task.

    Blasting small areas on body panels with a small, relatively low pressure blaster usually isn't a big concern. But there is the possibility of warping / distorting body panels when blasting (it's like hitting the panels with thousands of little tiny hammers that can stretch / warp the metal). It's especially an issue with larger, higher pressure equipment and on relatively large/flat areas like roofs, hoods, middle of doors, etc.

    The under-side of a vehicle is probably one of the messiest places to blast since you can't always use a containment system due to all the little nooks & crannies. And as I mentioned earlier, the little blasters with gravity feed hoppers won't work for this type of job with the nozzle pointed upward. So you'd want to look for a small siphon feed blaster instead.

    Hollow, boxed in areas of frames & under-body supports are especially hard to deal with. When rust gets into places like that you don't have a lot of choices. Short of replacement, the only other option (if possible) would be to cut open a side / section for access, blast & paint the inside, weld the section back on, and spray some rust proofing in through drain holes, etc.

    Comment


      #92
      Hopefully nothing is too bad on the celebrity. My camera on phone is broken or i would take a new pic of that bad rust spot. I removed the paint where its bad. Wow. What a rust spot.. Hopefully i can get this under control. Its gotta be 8 inch section there all rusted.

      Comment


        #93
        Plus i wish to get antique tags on this thing soon. Hopefully this year yet. Another thing i have noticed. In my 2 years of owning this car i have replaced every tail light at least 2 times.

        Not electrical problems not anything to do with the sockets etc. It just likes to blow lights for some reason. Like this time. I realized the left tail light. Dim side of light didnt work. It was blown. Filament broken.. I replaced it with a brand new bulb.. And drove 70 miles. And the next day i drove it i noticed the turnsignal wouldnt flash. Indicating a bad bulb. .. THE SAME BULB blew. It was brand new. I swear i have better luck with bulbs from the junk bin. I grabbed a bulb i found in the trunk. It didnt quit yet.

        Comment


          #94
          I know a couple came from a set of bulbs from ollies for 78 cents. One of those still works. The other died. I have a whole mismatched brand set of bulbs. I have a box of brand new Sylvanias from 1992 i found. I used a few of those. A couple napa bulbs. Even bulbs from foreign cars. Removing bulbs from junk cars. Just to have spares. Every bulb is tested. If it works i keep in the glove box. I try to get new ones but a couple days/weeks/months seems awful short lifespan for any brake light bulb. Headlights are usually first to blow. And this car still has 1 factory installed high beam guide light bulb that still works somehow.. I took it out to put newer bulbs in though. I had to replace the whole light holder because the screws were rusted in there so bad. The others came right out except 1 but i got that one out. . Other issue would be the front turnsignal sockets. Ground wire problems. Seems like an internal connection problem. Wires fine. But no ground to the bulb part.

          If anyone would have a recommendation for replacement. Weather its a oem part for a different design socket that fits with same bulb type.. Different car etc. Not going for fancy. Functionality with ease of use. Right now i have a ground wire jammed in with the bulb on both sides. Idk if anyone else has this problem. But would need replacement compatible to 1982-1985 celebrity. The front end is for a 82 but the 85 lighting is identical. 86 on up is different. Far as i know.

          Comment


            #95
            https://www.youtube.com/watch?v=oBacwjuwSso

            she still running

            Comment


              #96
              good to say too. i finally installed a (probably oversized) transmission cooler. i ripped it off a 1990 cierra at the junkyard someone must have put it on themselves. but it gets the job done. it actually seems to make a difference. that transmission would get so hot going over mountain that the engine temps would get over 220. now everything seems to hold steady.

              other problem. just stuck in traffic. that thing was heated up to about 250.

              after that the carb started acting up. driving home it ran increadably lean. got the exhaust glowing red. shut the key off it just spit fire out the tailpipe it was so hot. oil smelled like it exploded. coolant smelled like it exploded. that dumb vaporizer under carburetor was melted. the fuel filter was half gone.. WHERE DID IT GO?????????. not sure how fuel would eat a fuel filter. cheap filters these days. that and my spark plugs are all black now. but they have been on the vehicle for approx. 30k. may be around 28k but for how this thing runs. thats a long time on those plugs.

              changed the oil. turns out the 1991 buick century filter number gives you a longer filter. but it fits the same. bigger filter better. have not changed the coolant. idk if theres a true way to test coolant. or if it should just be replaced. but it does get hot. 250 is the most. but i either shut it off or got moving before it gets that bad. fan kicks on after 220? 210 maybe. there are times it may not kick on. but when i am moving faster than 30 mph it stays cool. if its hot 25 doesent really cool it down. but why is the fan not helping? the last time it was getting hot i shut the radio off and that fan was running full blast.

              Comment


                #97
                updates and all.

                ordered the carburetor rebuild kit for my 1979 carb. rebuilt it. cleaned the crud out of it. and besides the still non functional choke. is running better than ever. installed trans cooler. man that thing gets warm.

                I have successfully rebuilt the alternator all by myself. 1st time I ever did that. the old style gm alternators are pretty easy.. I got my donor parts from a 1977 buick lasabre that was refurbished with a better regulator.. for $5 I had the back cover, diodes and regulator better brushes and the rear bearing in the casing. and within 20 minutes I had mine back together working better. I was told by advanced auto 2 years ago when I had the system tested. that it had excessive ripple in voltage and should be replaced. well. it held on for 2 years. I actually get an extra volt now. and it actually stays above 12 volts at idle. I remember last winter. high beams lights heater on high wipers on high radio blasting. at a redlight idling for 3 minutes it went down to 8 volts and the radio turned off. don't stall don't stall. green light get going. 13 volts radio comes on. ok,. that needs fixed.

                I have my choke cable. if I close it all the way. hit petal 2 times crank it and pop the choke while cranking to about half. and hold the gas around 1200 rpm it fires right up 1st try and actually does not stall. and start driving. and after 2 minutes open the choke. some days its still touchy but its drivable.

                Comment


                  #98
                  Should be a 10si; those aren't too bad to rebuild.

                  Ken T.

                  Comment


                    #99
                    yep. I like how they give you a spot to stick a rod through to hold down the brushes for assembly.. the mazda Miata alternator does not have this for you. I gave up with that one. all soldered. not easily refurbished. 10si. I could rebuild that in a snap.


                    I have not been running junk gas since the carb rebuild. and. replaced the filter. but just yesterday the darn float stuck open again and flooded the carb.. my fresh rebuild. I don't understand it.. I really don't want to deal with this all the time. idk if there is a fix to that or if its just gonna do that. at least it is not a every 15 minute problem any more. the old carb before this. driving. sitting at a red light. stalls. hold it to the floor. ok its flooded. hit carb with wrench. good to go., get to the next red light. floods out and stalls. COME ON. broke a hole in the carburetor. then it didn't do it. rebuilt the other carb the next day. but 1 time in the last month isn't bad. but I am hoping it is not a returning issue

                    Comment


                      well well. I knew that old steering column was fishy. it wasn't even the original. its not the same color.

                      I had to do something. the easiest option was to just slap a whole new column in.. the entire key linkage thing was broken apart. the 2 bolts that bolt into aluminum around where the shifter bracket is underneath were broken. along with a few other bugs. I snagged a steering column from a 1986 buick century at the local yard. and the color matches perfectly to my interior. that was just dumb luck. as that buick was the only thing that I could use that I am sure of.. not sure about throwing a 4 speed shift one into a 3 speed car. buick had a 3 speed. nothing else did. . man that key turns like butter. starts on the click where its supposed to. not half a click past as far as it goes. its nice to have properly functioning parts.

                      and somehow it seems like this thing has a noticeable amount more power after I dumped in a can of stp oil treatment and NOS octane booster.

                      can't complain much, just rolled 186k. I think the engine could use an overhaul. but astro van needs inspected. buick roadmaster needs finished. buick seems to be first in like for vintage plates. its been not used for a while, plates, inspection and insurance is out of date. so if I can get the vintage tags on it I might as well. not like I am going to drive a 12 mpg boat 68 miles a day.

                      maybe I should get that 95 chevy metro. gas milage. celebrity can get vintage plates then

                      Comment


                        Awesome. Amazing. Old girl is now a part of the 200k

                        Comment


                          Wonderful! Happy you have kept her on the road!

                          Look me up on Facebook

                          Comment


                            I know i havent been on for a while here. But mostly because ive been busy. But the old celebrity is here to stay. May have some bugs still but hopefully soon itll get fixed. It reached 200k. If this motor dies someday ill rebuild or replace.
                            This car if something happens to it. Ill just never be the same without it. Been through a lot with her. 3 years 50k. Longest ive ever owned any car. Ive had a connection to this car since she found me. And i can say that. I wasnt looking for a car. Me and my buddy were at a garage. And another guy was loading it up. If i wasnt there that exact day at that exact time. This car would have ended up at a scrap yard. End of the line. But i saved her. Its just weird. Driving home with it. Even the seating position was perfect. Only to find out this seat doesnt adjust at all. And its perfect. Its got plenty of headroom for me. Almost 6 foot. Tall. The only thing im debating is carburetor or fuel injection now. And if i want to do a 5 speed swap or keep the 3 speed auto. And if the trand ever dies. Maybe go for a 4 speed auto. Since thats a simple swap. . these days im on the hunt for a good hood. Some miscelanious parts. And a paint job. Once rhe hood and rust is fixed. A paint job will make her look better. Then i gotta learn how to care for shiney paint.

                            Comment


                              I know how you feel. I felt that way about my very first ride; lost it in a accident nearly 28 years ago. I still get pretty attached to to my ride. I suppose in the case of the a-body car....it was my first *new* car, a '96 Century Limited. My wife and I logged over 150k on it, even taking it up to the mid-west. It's been sitting in the garage for the last 5 years, waiting for a transmission. I also have a '95, which has served as my daily driver for the last 9 years, although it too has been laid up a lot lately....

                              Ken T.

                              Comment


                                Originally posted by cody1234 View Post
                                I know i havent been on for a while here. But mostly because ive been busy. But the old celebrity is here to stay. May have some bugs still but hopefully soon itll get fixed. It reached 200k. If this motor dies someday ill rebuild or replace.
                                This car if something happens to it. Ill just never be the same without it. Been through a lot with her. 3 years 50k. Longest ive ever owned any car. Ive had a connection to this car since she found me. And i can say that. I wasnt looking for a car. Me and my buddy were at a garage. And another guy was loading it up. If i wasnt there that exact day at that exact time. This car would have ended up at a scrap yard. End of the line. But i saved her. Its just weird. Driving home with it. Even the seating position was perfect. Only to find out this seat doesnt adjust at all. And its perfect. Its got plenty of headroom for me. Almost 6 foot. Tall. The only thing im debating is carburetor or fuel injection now. And if i want to do a 5 speed swap or keep the 3 speed auto. And if the trand ever dies. Maybe go for a 4 speed auto. Since thats a simple swap. . these days im on the hunt for a good hood. Some miscelanious parts. And a paint job. Once rhe hood and rust is fixed. A paint job will make her look better. Then i gotta learn how to care for shiney paint.
                                Hey Cody, I know how that goes! It's great to take something that others have given up on and make it worthwhile again. That's how several of my cars became into my possession. Notably, my 88 Ciera XC which was being used to drive around as a yard car on a junkyard!

                                Taking care of shiney paint is not as hard as you think! Just a wax job a couple times a year is all it needs! It always is such a good feeling to drive around in a fresh, glistening glossy painted car!

                                Originally posted by Century7667 View Post
                                I know how you feel. I felt that way about my very first ride; lost it in a accident nearly 28 years ago. I still get pretty attached to to my ride. I suppose in the case of the a-body car....it was my first *new* car, a '96 Century Limited. My wife and I logged over 150k on it, even taking it up to the mid-west. It's been sitting in the garage for the last 5 years, waiting for a transmission. I also have a '95, which has served as my daily driver for the last 9 years, although it too has been laid up a lot lately....

                                Ken T.
                                Plan a trip to AL and bring that transmission here. We can make it work like new again!

                                Look me up on Facebook

                                Comment

                                Working...
                                X