Announcement

Collapse
No announcement yet.

1993 Buick Century 3.3L New To Me (Some Problems)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I'll get on that when I get home and report back.
    ________________________________________
    My god... It's full of cars!

    Comment


      #17
      If you still have some misfiring, one thing that can be overlooked is the spark plug wires. Most aftermarket ones are way longer than they need to be. I had a misfire issue on my 3.3 Century recently. The cause was the plug wires going to the rear bank resting on the exhaust and arcing on it!
      Daniel
      Kaiser George IX: 1996 Buick Century Special wagon. 214-SFI. 227k miles. Never gonna give you up, never gonna let you down. First documented LX9 swap in an A-body! Click here to read my build thread!
      Goldilocks: 1992 Buick Century Special sedan. 204-MFI. 132k miles.
      Susana: 1993 Buick Century Custom wagon. 204-MFI. 121k miles. No longer with us.

      Comment


        #18
        Well, no vacuum leaks that I could find, AND my cheap MAF sensor came in yesterday. Installed it this morning. The thing looks like absolute garbage and I gave it about a 10% chance of even being as good, less of it fixing my problem... but I must have won the parts-bin lottery because not only does it work, but I have experienced ZERO hesitation during acceleration and the car seems to accelerate faster than it ever has. Surprised me getting on the highway after warming her up. Lots of power indeed.

        I still have a lean code for the O2 sensor, but I'm wondering if the exhaust leak is contributing to that, or if the sensor is bad. I still need to test it.

        Either way, this MAF sensor seems to have solved my problem, I took the car on a good two hour test drive through multiple regimens of driving and not once did the problem come back. I'm still hesitant to say it's fixed beyond a shadow of a doubt, but my confidence is high.

        Thank you, everyone, for all of your help, and I'm sure you'll see me around, hopefully helping out as I learn more about this wonderful car.

        Thanks again!

        Old and Busted (?)
        https://i.imgur.com/ByOeWqf.jpg

        New "Hotness" (?)
        https://i.imgur.com/ewcJdcZ.jpg


        And here's some photos of the car. For $800 I am certainly very happy.

        https://imgur.com/a/OETtGX1
        Last edited by PETC; 10-14-2018, 07:48 PM.
        ________________________________________
        My god... It's full of cars!

        Comment


          #19
          Originally posted by PETC View Post
          Also, I've seen in a few other communities I've been a part of over the years that they usually have access to an online service manual. Is there something like that out there or should I head to ebay? Thanks!
          Check out alldatadiy.com

          Comment


            #20
            Nice looking car! We have a white one with maroon interior and a light blue with blue like yours (2 rear ash trays, can't figure out why some do and some don't).
            What is your added feature under the rear defogger switch?
            Jerry

            Comment


              #21
              Thanks! It's a broken off hook attached with a command strip. Probably taking it out. I assume it was used for a garbage bag by the PO. I was thinking about the ashtrays because I swear my old one had two in the back but I didn't have any pictures to prove it. I just figured it was either only an option in '91 or it was an optional "Smokers Package" maybe.

              I have power tilt seats, so maybe that has something to do with it too.
              ________________________________________
              My god... It's full of cars!

              Comment


                #22
                Great deal for $800.00. Nice car.

                Comment


                  #23
                  For 800 bucks, I would rock it.. Usually they have rust abound by now, and your appears to be pretty clean.
                  Brian - Carpe Diem

                  I dont have to love my president, or any god, to love my country!!
                  More people have died in the name of "God" than in all wars combined thruout history
                  01 Pontiac Aztek GT AWD 127k - 04 GMC Envoy SLT XUV 193k

                  Comment


                    #24
                    Still got a code 44 popping up. Getting my exhaust leaks fixed soon, I guess I'll see if I'm still getting the lean code when that's fixed.

                    I bought an O2 Sensor because I was at the parts store and they had it in stock for cheap, so if it persists after getting the exhaust fixed I'll replace it just for the hell of it and see if it works.

                    Its a Bosch and I was reading on here that they are garbage. Made me think about just returning it and buying a Denso.
                    ________________________________________
                    My god... It's full of cars!

                    Comment


                      #25
                      Return it and get a Delphi
                      Brian - Carpe Diem

                      I dont have to love my president, or any god, to love my country!!
                      More people have died in the name of "God" than in all wars combined thruout history
                      01 Pontiac Aztek GT AWD 127k - 04 GMC Envoy SLT XUV 193k

                      Comment


                        #26
                        Will do! Thanks for the info!
                        Last edited by PETC; 10-18-2018, 04:13 PM.
                        ________________________________________
                        My god... It's full of cars!

                        Comment


                          #27
                          Yup......Delphi. Mine throws codes with Bosch.

                          Comment


                            #28
                            Bosch might work on European cars but I avoid their products like the plague.

                            The hub falling off the shaft of the water pump is still my all time favorite. Glad my daughter wasn't in an accident because of it.

                            Jerry

                            Comment


                              #29
                              Damn! Yeah my Delphi sensor showed up yesterday. Hoping to get my exhaust fixed sometime in the next few weeks and then I'll replace the sensor.

                              I got another code 13 the other day on my first long drive down I5 so I have a pretty good idea that the O2 sensor in there is bad, but I don't want to replace it until I get all of my leaks fixed.
                              ________________________________________
                              My god... It's full of cars!

                              Comment


                                #30
                                Since the O2 sensor is in the manifold, not downstream from the exhaust leaks, you should be able to replace it without causing any issues.
                                Brian - Carpe Diem

                                I dont have to love my president, or any god, to love my country!!
                                More people have died in the name of "God" than in all wars combined thruout history
                                01 Pontiac Aztek GT AWD 127k - 04 GMC Envoy SLT XUV 193k

                                Comment

                                Working...
                                X