Page 1 of 97 1231151 ... LastLast
Threads 1 to 20 of 1936

Forum: Mechanical & Electrical Troubleshooting

Is something not working right? Learn how to fix it in our troubleshooting forums.

  1. Help with Rear Brakes

    Started by Cressida, 03-27-2020 11:50 PM
    • Replies: 4
    • Views: 303
    Yesterday, 02:31 AM Go to last post
  2. Is my 86 Century 3.8 Transmission Shot?

    Started by T Type, 02-16-2020 05:10 PM
    • Replies: 8
    • Views: 236
    03-25-2020, 09:35 PM Go to last post
  3. Instrument panel fuse blowing instantly

    Started by aspenwillow, 03-07-2020 01:29 AM
    • Replies: 7
    • Views: 211
    03-17-2020, 03:24 AM Go to last post
  4. 4t60 first speed only no 1-2 3shift

    Started by Glacier63, 03-07-2020 04:24 PM
    • Replies: 0
    • Views: 53
    03-07-2020, 04:24 PM Go to last post
  5. 4t60 no drive first start after repair

    Started by Glacier63, 03-03-2020 07:00 AM
    • Replies: 3
    • Views: 73
    03-03-2020, 02:55 PM Go to last post
  6. 1990 Cutlass Ciera S 3300 stalls at stops

    Started by keantoken, 01-03-2020 11:32 AM
    3 Pages
    1 2 3
    • Replies: 32
    • Views: 1,042
    01-19-2020, 02:17 AM Go to last post
  7. 1988 pontiac 6000 shifter cable

    Started by harley42, 01-11-2020 07:18 PM
    • Replies: 1
    • Views: 136
    01-14-2020, 11:04 PM Go to last post
  8. Not able to pull diagnostic codes

    Started by tfricke, 12-31-2019 08:34 PM
    • Replies: 2
    • Views: 169
    12-31-2019, 11:49 PM Go to last post
    • Replies: 11
    • Views: 471
    12-17-2019, 03:13 AM Go to last post
  9. Evap system oddities & issues

    Started by Spacecataz, 12-13-2019 04:04 AM
    • Replies: 0
    • Views: 149
    12-13-2019, 04:04 AM Go to last post
  10. 1990 Iron Duke stumbles at idle?

    Started by Bdevil, 11-11-2019 11:12 AM
    • Replies: 2
    • Views: 300
    11-11-2019, 09:29 PM Go to last post
  11. Power Steering Pump Removal

    Started by Whistler5.1, 10-26-2019 12:18 PM
    • Replies: 5
    • Views: 691
    10-31-2019, 09:02 PM Go to last post
  12. Crankshaft Position Sensor stuck

    Started by aspenwillow, 10-28-2019 02:07 AM
    • Replies: 2
    • Views: 457
    10-29-2019, 02:36 PM Go to last post
  13. Power brake booster

    Started by Mur, 10-25-2019 10:48 AM
    • Replies: 2
    • Views: 330
    10-25-2019, 10:02 PM Go to last post
  14. 86 Century 3.8 Leaking Oil Pan Gasket

    Started by T Type, 09-30-2019 05:31 PM
    • Replies: 4
    • Views: 429
    10-16-2019, 11:00 PM Go to last post
  15. 3300 mass air flow sensor Hell!

    Started by bluetrane2028, 09-29-2019 07:58 PM
    • Replies: 1
    • Views: 329
    10-01-2019, 04:34 PM Go to last post
  16. A/C system diagnosis?

    Started by 73blazer, 05-30-2017 03:00 PM
    2 Pages
    1 2
    • Replies: 19
    • Views: 2,882
    09-12-2019, 03:30 PM Go to last post
  17. 2.8L Rear Valve Cover Gasket

    Started by Sigurd Jarlson, 08-31-2019 07:52 PM
    • Replies: 3
    • Views: 480
    09-02-2019, 12:49 AM Go to last post
  18. problem Egr valve

    Started by Glacier63, 08-30-2019 08:06 AM
    • Replies: 5
    • Views: 540
    08-31-2019, 01:56 PM Go to last post

Page 1 of 97 1231151 ... LastLast

Forum Information and Options

Moderators of this Forum

Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
More than 15 replies or 150 views
Hot thread with unread posts
More than 15 replies or 150 views
Hot thread with no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
VigLink badge