Page 2 of 98 FirstFirst 12341252 ... LastLast
Threads 21 to 40 of 1951

Forum: Mechanical & Electrical Troubleshooting

Is something not working right? Learn how to fix it in our troubleshooting forums.

  1. Help with Rear Brakes

    Started by Cressida, 03-27-2020 11:50 PM
    • Replies: 4
    • Views: 924
    04-05-2020, 02:31 AM Go to last post
  2. Is my 86 Century 3.8 Transmission Shot?

    Started by T Type, 02-16-2020 06:10 PM
    • Replies: 8
    • Views: 978
    03-25-2020, 09:35 PM Go to last post
  3. Instrument panel fuse blowing instantly

    Started by aspenwillow, 03-07-2020 02:29 AM
    • Replies: 7
    • Views: 866
    03-17-2020, 03:24 AM Go to last post
  4. 4t60 no drive first start after repair

    Started by Glacier63, 03-03-2020 08:00 AM
    • Replies: 3
    • Views: 484
    03-03-2020, 03:55 PM Go to last post
  5. 1990 Cutlass Ciera S 3300 stalls at stops

    Started by keantoken, 01-03-2020 12:32 PM
    3 Pages
    1 2 3
    • Replies: 32
    • Views: 2,687
    01-19-2020, 03:17 AM Go to last post
  6. Not able to pull diagnostic codes

    Started by tfricke, 12-31-2019 09:34 PM
    • Replies: 2
    • Views: 572
    01-01-2020, 12:49 AM Go to last post
    • Replies: 11
    • Views: 1,124
    12-17-2019, 04:13 AM Go to last post
  7. Evap system oddities & issues

    Started by Spacecataz, 12-13-2019 05:04 AM
    • Replies: 0
    • Views: 458
    12-13-2019, 05:04 AM Go to last post
  8. Power Steering Pump Removal

    Started by Whistler5.1, 10-26-2019 12:18 PM
    • Replies: 5
    • Views: 1,435
    10-31-2019, 09:02 PM Go to last post
  9. Crankshaft Position Sensor stuck

    Started by aspenwillow, 10-28-2019 02:07 AM
    • Replies: 2
    • Views: 846
    10-29-2019, 02:36 PM Go to last post
  10. Power brake booster

    Started by Mur, 10-25-2019 10:48 AM
    • Replies: 2
    • Views: 685
    10-25-2019, 10:02 PM Go to last post
  11. 86 Century 3.8 Leaking Oil Pan Gasket

    Started by T Type, 09-30-2019 05:31 PM
    • Replies: 4
    • Views: 828
    10-16-2019, 11:00 PM Go to last post
  12. 3300 mass air flow sensor Hell!

    Started by bluetrane2028, 09-29-2019 07:58 PM
    • Replies: 1
    • Views: 648
    10-01-2019, 04:34 PM Go to last post
  13. A/C system diagnosis?

    Started by 73blazer, 05-30-2017 03:00 PM
    2 Pages
    1 2
    • Replies: 19
    • Views: 3,952
    09-12-2019, 03:30 PM Go to last post
  14. 2.8L Rear Valve Cover Gasket

    Started by Sigurd Jarlson, 08-31-2019 07:52 PM
    • Replies: 3
    • Views: 831
    09-02-2019, 12:49 AM Go to last post
  15. problem Egr valve

    Started by Glacier63, 08-30-2019 08:06 AM
    • Replies: 5
    • Views: 975
    08-31-2019, 01:56 PM Go to last post
  16. Critter damage to fuel line

    Started by Sigurd Jarlson, 08-12-2017 01:42 PM
    • Replies: 7
    • Views: 1,845
    08-25-2019, 12:49 AM Go to last post
  17. 1993 Century Limited - some questions

    Started by AlexMTL, 07-30-2019 03:49 AM
    • Replies: 4
    • Views: 1,011
    08-16-2019, 11:26 AM Go to last post
  18. Tilt Wheel and high beam

    Started by gbb, 07-10-2019 02:19 AM
    • Replies: 0
    • Views: 669
    07-10-2019, 02:19 AM Go to last post

Page 2 of 98 FirstFirst 12341252 ... LastLast

Forum Information and Options

Moderators of this Forum

Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
More than 15 replies or 150 views
Hot thread with unread posts
More than 15 replies or 150 views
Hot thread with no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
VigLink badge