Results 1 to 5 of 5

Thread: ECU, Coil Packs, ICM

  1. #1
    Senior Member ochy38's Avatar
    Join Date
    Sep 2007
    Location
    Utica, NY
    Vehicle
    1989 Chevrolet Celebrity
    Posts
    455

    Default ECU, Coil Packs, ICM

    (OOPS, title meant to be ECM)

    I have an ECM out of a convertable cavalier w/ a 2.8l. I swapped mine initially to try to diagnose a problem, and left it in there for maybe 5,000 miles. It worked fine in my '89 celebrity EXCEPT that the a/c compressor wouldn't come on and the radiator fan wouldn't either. It is possible that the a/c and fan signals are just on a different pin, but i'm not sure. I'm just offering it up here in case anyone is interested, PM me an offer if interested.

    I also have the three original coil packs out of my 2.8l. I changed them trying to diagnose a problem and it ended up that they were not the problem. I tested them a while back and they were fine, just dont remember the readings off the top of my head. PM me an offer and we'll discuss.

    Last, but not least, I have the original ignition control module off of my 2.8l. When trying to diagnose the aforementioned issue, my new coils and ICM came together. I have not tested this, but the car ran completely fine with it so im assuming its fine. Again, PM me an offer and we'll discuss.

    If no takers in the next couple days, they'll be going on eBay.
    Last edited by ochy38; 03-07-2009 at 08:09 PM.
    1989 Celebrity 2.8l v6 115,000 miles
    Cold Air Intake-----------------------Trans-am Spoiler
    Cherry Bomb Turbo Muffler------225/50/R16 Hankook's
    Custom Dual Exhaust Setup---Alpine CDA-D855
    MA-Audio 12" Sub------------------Soundstorm Amp
    --------Custom "firm/lowered" suspension---------



  2. #2
    Senior Member 85_Ciera_Rebuild's Avatar
    Join Date
    Sep 2007
    Location
    Kansas
    Posts
    6,731

    Default

    Quote Originally Posted by ochy38 View Post
    ECM out of a ..cavalier w/ a 2.8l....worked fine in my '89 celebrity EXCEPT that the a/c compressor wouldn't come on and the radiator fan wouldn't either.

    I also have the three original coil packs out of my 2.8l.

    Last, but not least, I have the original ignition control module off of my 2.8l.

    If no takers in the next couple days, they'll be going on eBay.

    It might have been your temp sending unit. AC-Switch, relay to fan, or ECM was not sending out current to fan relay.

    BTW, I have no idea what these fit....

    ECM
    Coil Pack
    Ignition CM -

    I have a 88 Beretta 2.8, but it appears your parts might be different...pictures tell more

  3. #3
    Senior Member ochy38's Avatar
    Join Date
    Sep 2007
    Location
    Utica, NY
    Vehicle
    1989 Chevrolet Celebrity
    Posts
    455

    Default

    everything is out of an 89 celebrity with a 2.8l, minus the ECM but it fits. I will get pictures later.

    BTW, with the ECM i put my original one back in and the a/c and rad fan worked fine, so its definately a ECM-related issue. Someone else mentioned to me (believe it was turbokinetic) that they had the same problem and it was just the signal got changed to a different pin for whatever model ECM they put in, but i do believe it was a different engine then i have.
    1989 Celebrity 2.8l v6 115,000 miles
    Cold Air Intake-----------------------Trans-am Spoiler
    Cherry Bomb Turbo Muffler------225/50/R16 Hankook's
    Custom Dual Exhaust Setup---Alpine CDA-D855
    MA-Audio 12" Sub------------------Soundstorm Amp
    --------Custom "firm/lowered" suspension---------

  4. #4
    Senior Member
    Join Date
    Jan 2009
    Location
    NEW BEDFORD, MA
    Posts
    232

    Default

    is there a part number on the ECM??
    1985 Chevrolet Corvette
    2009 Chevrolet Avalanche LT
    2011 Volvo C30

    Remember: No matter where you go, there you are....

  5. #5
    Senior Member 85_Ciera_Rebuild's Avatar
    Join Date
    Sep 2007
    Location
    Kansas
    Posts
    6,731

    Default

    Quote Originally Posted by T5258 View Post
    is there a part number on the ECM??
    Yea....

    Here's some applications for that ECM

    01227730

    * 1987 2.0 L4 TBI “1” LL8
    * 1988 2.0 L4 TBI “1” LL8 (early)
    * 1987-89 2.8 V6 PFI “W” LB6 (exc. “W” body)
    * 1988-94 3.1 V6 PFI “T” LH0 (exc. “W” body)
    * 1990-92 5.0 V8 TPI “F” LB9
    * 1990-92 5.7 V8 TPI “8” L98 (“F” body)
    Last edited by 85_Ciera_Rebuild; 03-09-2009 at 02:21 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
VigLink badge