Results 1 to 3 of 3

Thread: Factory radio not working

  1. #1
    Senior Member
    Join Date
    Aug 2016
    Posts
    113

    Default Factory radio not working

    Hey all , it's the original cassette player radio. Has power but will not play either radio or cassette. No stations numbers come on but when you hit the SET button it's shows ( set)



  2. #2
    Junior Member LG7rumble's Avatar
    Join Date
    Aug 2016
    Location
    New England
    Vehicle
    89 Century 3300
    Posts
    11

    Default

    I pulled this from a car at work with plans to use it as a guinea pig for an aux-input mod, but I haven't gotten around to it yet (plus my car has the older style radio plugs). Haven't tested it yet, so not sure if it works or what color the illumination is, but I can throw it in a car and check if you don't think you can fix your current unit



    Code:
    21 pin connector.
    Not equipped for steering wheel controls.
    Radios equipped with "Delco Loc" anti-theft option must have security code to operate.
    Use barb/barbless antenna adapters 16169591, 16169581, 16169601 or 16169611 when interchanging '93 and older with '94 and newer radios.
    Knobs & face plate colors vary between years.

  3. #3
    Senior Member
    Join Date
    Aug 2016
    Posts
    113

    Default

    My plans were to try fit a S10 chevy 2000 2003 stero into my 1994 buick century wagon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •