Results 1 to 3 of 3

Thread: 2.5L 1992 Buick Century - high idle problem

  1. #1
    Junior Member
    Join Date
    Dec 2017
    Location
    JOH JAH
    Vehicle
    1992 Buick Century Wagon
    Posts
    1

    Default 2.5L 1992 Buick Century - high idle problem

    Experiencing an odd high-idle issue with my 1992 2.5L "Iron Duke" Buick Century Wagon. The colder it is, the more pronounced the problem, but it occurs to some extent at all temperatures.

    Idle is very high upon initial start-up. Stabbing the accelerator will drop rpms some but certainly not into the normal range. Idle speed is more acceptable once in gear and/or at operating temp, but it's always higher than it should be no matter the circumstance. Fuel economy has dropped considerably and there is a new odor from the exhaust that wasn't there before the problem manifested.

    The car has just 42K original miles and had a very thorough tune-up less than 3K miles ago. It did, however, sit in storage last winter for close to six months.

    Ideas/suggestions?

    Also: recommended brand / part no. for Iron Duke valve cover gaskets? I went Fel-Pro at the time of the tune-up and it started leaking again less than a year after installation.



  2. #2
    Senior Member Keiths1976's Avatar
    Join Date
    Dec 2013
    Location
    Florida
    Vehicle
    1995 buick century custom
    Posts
    1,180

    Default

    Is the check engine light on ? . . I can give a few cheap ideas first is CTS 16bucks or less ( coolant temperature sensor ) it controls open and closed loop along with warm up process as well as the idle air control valve and o2 sensor. . Since you have a fuel odor check them first bad ignition coil going would give u a misfire a vacuum leak . But always check spark fuel and air and rule out one at a time . Spark plugs ,wires ,coils . Air -mass air flow sensor map sensor ,vacuum leak , idle air valve . Fuel - fuel pressure regulator since u have a older 2.5 iron duke with the TBi injector on top see if u smell raw fuel through the the air filter housing Little is ok but raw means to much fuel pouring in bad I joritor or running rich . Which like I said CTS sensor or O2 sensor cause the car to run rich and affect fuel economy .

  3. #3
    Senior Member 85_Ciera_Rebuild's Avatar
    Join Date
    Sep 2007
    Location
    Kansas
    Posts
    6,518

    Default

    Maybe sucking air....plug off brake-booster's vacuum line, at intake.

    Extra air is required for high idle. so, intake gasket leak, vacuum line leak...etc...extra air getting in somewhere.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •