Results 1 to 3 of 3

Thread: Crankshaft Position Sensor stuck

  1. #1
    Junior Member
    Join Date
    Jun 2019
    Posts
    6

    Default Crankshaft Position Sensor stuck

    1989 Chevy Celebrity 2.8 and I can't get the crankshaft sensor out. I undid the bolt but I believe the O-ring is holding it back. Most of the exposed plastic has already been broken off. Any suggestions on how to get it off? Looked through the threads and saw that people struggle with this but no instructions on removing it



  2. #2
    Senior Member
    Join Date
    Oct 2013
    Location
    Northwest Lower Michigan
    Vehicle
    1989 Celebrity CL 4 door 3.1, 1989 Cutlass Cruiser 3.1
    Posts
    208

    Default

    I think there is a ring of carbon that builds up and makes it difficult to pluck out after a long time. I've done several and one was when it was below zero outside. I hooked a length of fish tank hose to a tube of carb cleaner and kept spraying it to soak and dilute the carbon build up. There might be something better to use. I just kept lifting it and spinning it as I applied pressure upwards. Careful use of a putty knife helped, though most of my plastic snapped too. I may have put a small vise grip on what was left to help lift it out too. It took hours but eventually I got it out. Would probably be a good idea to change the oil if you've now got a whole can of carb cleaner in the crankcase.

    I see why every aftermarket one has a steel plate in place of a plastic tab. It would also be beneficial to just reach down and pluck it out and clean it maybe once every few years if you remember, just to make sure you can get it out when you really need to. Like maybe when you're already back there to change spark plugs.
    1989 Celebrity CL 4 door, 3.1 MPFI, 4 speed auto, summer daily driver
    1989 Cutlass Cruiser wagon, 3.1 MPFI, 4 speed auto, special summer ride
    1996 Cherokee XJ 4 door, 4.0, 5 speed, winter daily driver & towing vehicle
    1991 Tracker 2 door, 1.6, 5 speed, needs work
    Previously several Celebritys, 6000s, & 2 U-vans

  3. #3

    Pontiac6ksteawd's Avatar
    Join Date
    Sep 2007
    Location
    Brighton, CO
    Vehicle
    GMC Envoy XUV, Pontiac Aztek GT
    Posts
    1,781

    Default

    Its a fairly common problem. I fought with mine for what seemed like hours on my 6000 STE AWD. But it finally gave me that satisfying pop, and out it came. The key for me was to keep turning it while applying pressure.
    Brian - Carpe Diem

    I dont have to love my president, or any god, to love my country!!
    More people have died in the name of "God" than in all wars combined thruout history
    01 Pontiac Aztek GT AWD 125k - 04 GMC Envoy SLT XUV 192k - 05 Buick Rendezvous CXL Sport Plus 61k

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
VigLink badge