Results 1 to 8 of 8

Thread: 1993 Olds Ciera 3.3L with front end rattle

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Junior Member
    Join Date
    Sep 2020
    Location
    Massachusetts
    Vehicle
    1993 Olds Cutlass Ciera S, 3.3L
    Posts
    2

    Default 1993 Olds Ciera 3.3L with front end rattle

    [IMG]12-10-10(1)001.jpg[/IMG]

    93 Olds Ciera with 132K original miles in excellent overall condition. Especially well maintained.

    Experiencing an intermittent front end (driver side) rattle. Ball joint, tie rod, stabilizer bar, brakes OK. Sounds just like a broken "stabilizer link" which this vehicle does not have. Recent front end alignment. Performance 100% in all regards.

    Any suggestions?

  2. #2
    Senior Member CorvairGeek's Avatar
    Join Date
    Dec 2014
    Location
    The Gem State
    Vehicle
    1992 Century Special 1996 Century Custom
    Posts
    829

    Default

    Wish I had a suggestion. I fight the front end noises with two of them. This spring, I replaced a bad strut on our '92 and bad inner tie rod ends on the '96, transmission mounts on both, and used a compatible grease on the engine cradle bushings (thought sure I had a bad one), greased the anti-sway bar engine cradle bushings , then aligned. Alignment techs note what great condition the cars are in, no work suggested. No change in my mystery clunks.

    I had been chasing them prior to that too. Thought sure I had a bad strut mount clunking once.
    Last edited by CorvairGeek; 09-13-2020 at 01:47 PM.
    Jerry

  3. #3
    Senior Member Keiths1976's Avatar
    Join Date
    Dec 2013
    Location
    Florida
    Vehicle
    1995 buick century custom
    Posts
    1,362

    Default

    I have teo that I did chase down for some time ... turns out the steering rack bolt loosen after 25 years before I replaced my rack . As the suspension compressed down and up puts the force on the 2 bolts holding the steering rack u will get a pop or clunk from it as well . Another thing by age is a strut mount on the strut . The ac delco stock strut mount has a rubber insulator between the Strut and plate that wears down and u will get a clunk . The top part of the mount won?t make noise on the body only when the suspension bottoms out or comes up is clunks .

  4. #4
    Junior Member
    Join Date
    Sep 2020
    Location
    Massachusetts
    Vehicle
    1993 Olds Cutlass Ciera S, 3.3L
    Posts
    2

    Default

    Thanks guys. Will look closer as it is nothing obvious. The sound is intermittent, even over imperfect pavement. The recent line up tech is awesome with the latest equipment, but still test drives. I will keep at it and when successfull will report.

  5. #5
    Senior Member
    Join Date
    Oct 2013
    Location
    Northwest Lower Michigan
    Vehicle
    1989 Celebrity CL 4 door 3.1, 1989 Cutlass Cruiser 3.1
    Posts
    247

    Default

    Lots of good ideas posted. It sounds to me like a brake pad rattle. Sometimes the anti rattle clips break and the pads rattle over bumps.

  6. #6

    Pontiac6ksteawd's Avatar
    Join Date
    Sep 2007
    Location
    Brighton, CO
    Vehicle
    GMC Envoy XUV, Pontiac Aztek GT
    Posts
    1,837

    Default

    I would suggest finding out why you dont have a front stabilizer. All vehicles were required to have them..

    Then I would be looking at the upper strut bearing plate, cracked spring in the strut, lower ball joint, CV axles, Hub Bearings, front brake heat/dust shield, frame of the car around the strut, lower control arm bushings.
    Brian - Carpe Diem

    I dont have to love my president, or any god, to love my country!!
    More people have died in the name of "God" than in all wars combined thruout history
    01 Pontiac Aztek GT AWD 125k - 04 GMC Envoy SLT XUV 192k - 05 Buick Rendezvous CXL Sport Plus 61k

  7. #7
    Junior Member
    Join Date
    Apr 2015
    Posts
    16

    Default

    Don't forget to check your wheel bearing also.

  8. #8
    Senior Member
    Join Date
    Oct 2013
    Location
    Northwest Lower Michigan
    Vehicle
    1989 Celebrity CL 4 door 3.1, 1989 Cutlass Cruiser 3.1
    Posts
    247

    Default

    Quote Originally Posted by Pontiac6ksteawd View Post
    I would suggest finding out why you dont have a front stabilizer. All vehicles were required to have them..
    I think the OP meant that these cars don?t have the stabilizer link. While most cars use the link at the end of the bar, our cars use a stabilizer bushing to contain the end of the bar.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
VigLink badge