Results 1 to 8 of 8

Thread: 89 6000 LE Stalling

  1. #1
    Junior Member
    Join Date
    Oct 2020
    Posts
    3

    Default 89 6000 LE Stalling

    Picked up an 89 6000 LE 2.8 recently with 55k, has issues running and shuts off after awhile. Does not start right away again generally until it cools down a bit.

    Previous owner threw some misc. odds and ends at it in hopes to get it running, fuel pump supposedly.

    While it was previously running it ran a little wonky and the oil pressure fluctuated as it idled.

    I know a tuneup is in order but haven't really had a chance to look into it yet as I'm waiting for a battery from costco, but just looking for tips and places where to start. Thanks!



  2. #2
    Senior Member Keiths1976's Avatar
    Join Date
    Dec 2013
    Location
    Florida
    Vehicle
    1995 buick century custom
    Posts
    1,365

    Default

    The list can be long man ... ignition control modular getting to hot and causing it to shut down , crank positioned sensor gets to hot and causes a no start , it?s a electrical sensor due to getting to hot . Also a bad battery / a bad alternator is not supply the amps needed to keep the car running the 10-12 volts. That?s only a few little things the fuel pressure regulator is getting weak causing it to vapor lock or the spring inside is sticking causing no fuel coming up to the fuel rail , yes she?s a low milage car but the rest is still by age where the environment can?t cause issues . I?d say start with a tune up and go from there we are here to help for sure .

  3. #3

    Pontiac6ksteawd's Avatar
    Join Date
    Sep 2007
    Location
    Brighton, CO
    Vehicle
    GMC Envoy XUV, Pontiac Aztek GT
    Posts
    1,861

    Default

    The very first place I would start is fuel injectors. I would bet at least 2-3 of them are bad, if not more. Need to get them ohmed out, and report back.
    Brian - Carpe Diem

    I dont have to love my president, or any god, to love my country!!
    More people have died in the name of "God" than in all wars combined thruout history
    01 Pontiac Aztek GT AWD 127k - 04 GMC Envoy SLT XUV 193k

  4. #4
    Senior Member
    Join Date
    Oct 2013
    Location
    Northwest Lower Michigan
    Vehicle
    1989 Celebrity CL 4 door 3.1, 1989 Cutlass Cruiser 3.1
    Posts
    272

    Default

    My experience has almost always been the crank sensor or ignition module. If it runs fine then shuts off like a switch. And won?t even attempt to fire until it cools off.

    I?ve been lucky when it comes to fuel injectors thankfully but I know others have had issues.

  5. #5
    Junior Member
    Join Date
    Oct 2020
    Posts
    3

    Default

    Thanks for the tips guys! The guy had changed the ignition control module, that I do know. I'll look into the other ignition stuff and injectors.

  6. #6
    Senior Member CorvairGeek's Avatar
    Join Date
    Dec 2014
    Location
    The Gem State
    Vehicle
    1992 Century Special 1996 Century Custom
    Posts
    833

    Default

    Heat makes failing injectors worse too. Some will even develop a short until they cool off.
    Jerry

  7. #7

    Pontiac6ksteawd's Avatar
    Join Date
    Sep 2007
    Location
    Brighton, CO
    Vehicle
    GMC Envoy XUV, Pontiac Aztek GT
    Posts
    1,861

    Default

    Quote Originally Posted by CorvairGeek View Post
    Heat makes failing injectors worse too. Some will even develop a short until they cool off.
    And on these, when one injector shorts, it takes out all 3 in the bank.
    Brian - Carpe Diem

    I dont have to love my president, or any god, to love my country!!
    More people have died in the name of "God" than in all wars combined thruout history
    01 Pontiac Aztek GT AWD 127k - 04 GMC Envoy SLT XUV 193k

  8. #8
    Junior Member
    Join Date
    Oct 2020
    Posts
    3

    Default

    New battery in, fuel filter is leaking bad so waiting on one. Inspecting plugs the wires broke apart so I'm putting new plugs, wires, and coils. After that I'll take a look into the injectors, thanks guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
VigLink badge